Probs with URL redirection and referring links :(

Status
Not open for further replies.
D

detsorgsekalf

Guest
#1
hello!

for some odd reason, StatsCounter won't show the links that people use to get to my site. I've installed the code on my splash page. clicking on the splash page leads to a smaller pop-up window, which also has the Statscounter code in it.

I'm also using a URL redirection service to cloak the original URL. I entered all of the URLs into my StatsCounter account though...

why does it still show referring links as my splash page and not the actual external links?

here is my site if you would like to check it out:

http://www.detsorgsekalf.norwegian.at

and the cloaked URL is http://ca.geocities.com/detsorgsekalf@rogers.com/


pleeeeease help me! :cry: this is driving me nuts!
 
#2
If you use the Statcounter in a pop-up window it cannot know the referrer.

Also framed sites like yours (i.e. with a cloaked url or a url redirection from the registrar to the hosting) do not support the use of the frames version of the counter (it will give an error), as it cannot get parent referrer infromation across domains (your domain name is on one domain, and your actual web site is on another domain).
 
D

detsorgsekalf

Guest
#3
hmm okay... (sorry if i'm a little slow understanding this stuff - i really appreciate the help though!)


k, so if i have the Statscounter code on my splash page and if i access it from the original URL, and if i don't have frames on that page, it should show the proper referring link right?


also.. i don't get why it says there are frames in my splash page when i right-click in that page. i went back to my source code, and there's only a table in there... no frames. i'm so confused!
 
#4
detsorgsekalf said:
hmm okay... (sorry if i'm a little slow understanding this stuff - i really appreciate the help though!)


k, so if i have the Statscounter code on my splash page and if i access it from the original URL, and if i don't have frames on that page, it should show the proper referring link right?


also.. i don't get why it says there are frames in my splash page when i right-click in that page. i went back to my source code, and there's only a table in there... no frames. i'm so confused!
Access your domain and click on View > souce code at the top of the browser - you'll see frames. Your hosting does not provide name servers (or you did not use them when registering teh domain name) therefore your domain name has to point to your hosting by cloaked url - that's where the frames come in.
 
D

detsorgsekalf

Guest
#5
okay i understand the frames thing now. ...no frames in the splash page with the original url... but there are frames in the redirected one.


now... is there anything i can do to make it so that i can see what the real referring links are? (instead of it just listing my homepage?)
 
#6
detsorgsekalf said:
okay i understand the frames thing now. ...no frames in the splash page with the original url... but there are frames in the redirected one.


now... is there anything i can do to make it so that i can see what the real referring links are? (instead of it just listing my homepage?)
The only thing you can do is acquire proper hosting where you get name servers. This pretty much rules out free web space from ISP's.
 
D

detsorgsekalf

Guest
#7
ooh ooh okay i'm not sure what i did (i haven't changed the website at all... was just messing around with my statscounter account)

and now it shows me this in the Came From section:


Referring Link
2 forum.statcounter.com/phpBB2/viewtopic.php?p=20206


Internal Links set for this project (update in 'installation and configuration' > 'edit settings'):
'http://detsorgsekalf.warofgods.com'
'http://www.detsorgsekalf.norwegian.at'
'http://ca.geocities.com/detsorgsekalf@rogers.com/'
'http://detsorgsekalf.norwegian.at'
'http://www.detsorgsekalf.warofgods.com'



does this mean it works now?
 
#10
detsorgsekalf said:
yup i figured that, but it never showed external links before...


before i changed my settings, it would show me a list of referring links that looked something like this:

http://www.detsorgsekalf.norwegian.at
http://ca.geocities.com/detsorgsekalf@rogers.com/index.htm
http://ca.geocities.com/detsorgsekalf@rogers.com/main3.htm
Probably nobody accessed your site directly that way from a different place like the forum.

If I click on your domain name you will not get that - coming up, watch out for a visitor frm HSE-Sympatico......



LATER: except that I cannot get to your page at all right now. :cry:
 
D

detsorgsekalf

Guest
#13
okay yeah, i don't see any referring link info any more... aaah where's it gone?!

oh btw, i've made my stats public, so you can peek into it... in the popup window, you'll see a little link saying Stats in the lower right hand corner.
 
Status
Not open for further replies.
Top