Recent Pageload: Unknown?

#1
For about a week now, my stats for Recent Pageload activity no longer show the specific page titles. I am getting hits, stats show that, with all the other info but in every single case now, "Unknown" is all the info I can find for what pages are being visited. I don't know what happened...? :confused:
 
#2
Using the html-only version of the tracker? Javascript is needed to get the page title.

When the visitor is a robot you will not have a page title of the hit, nor even a page url.
 
#4
I have developed the same problem, except that it occurs indiscriminately. Some hits show the page title that was visited and others do not --- even when the same StatCounter code is used in both pages.

For what it's worthy, I might mention that my WordPress host seems to have recently stopped accepting javascript. But I'm not sure why that would matter, since (1) my code does not seem to contain javascript and (2) the identical script works fine on some pages and identifies the page title.

Any guidance would be appreciated.
 
#6
Sorry, I should have been more clear. I was thinking of URLs and Page Titles as the same thing. (I actually didn't know that page titles could be displayed in StatCounter reports. All I've ever seen reported are URLs ---and that suits me just fine.)

I was responding to Founders4ever orginal post, which noted that "Recent Pageload Activity" now shows "Unknown" instead of page titles (or, in my case, URLs).

So, StatCounter tells me that some visited pages are "unknown," even though they contain the same code that, when place on other pages, will record the visited page URL.

Hope that clarifies.

Any suggestions?
 
#8
This conversation has really cleared things up for me even more, as my situation had been indiscriminate, too, sometimes showing URL, and/or page titles, sometimes not...suddenly, nothing but Unknown. On Recent Visitor AND Recent Pageload Activity. It's gotten worse since my first post. It's a little scary. A robot might be the culprit, then....
 
#9
It's not a bot. It's me, visiting my own site.

With blocking cookie turned off, I test my own links to see if they register with StatCounter. Some pages will return the URL and some pages will return Unknown. And like Founders4ever, it occus on both Recent Visitor AND Recent Pageload Activity.

There are some pages that ALWAYS return the URL and some pages that NEVER return the URL ---even though they contain EXACTLY THE SAME HTML CODE. And again, I'm the visitor, not a bot. (And, for what it's worth, for the past week or so, I have not been able to create a new page that will return the URL.)

Of course, I don't know whether the problem is the same for my actual visitors. I do see that some of the same pages that I visit are also visited by others. (In other words, I get the URL for my visits and others' visits.) But I don't know what pages might work for me but not for others', since UNKNOWN tells me nothing about what pages they might have been trying to load.
 
#11
Both IE and Firefox? On different computers? From different physical locations? On iphones and ipads, too?

And maybe I'm not being clear. I want to know the URL of the page on my site that is being visited, not the referring URL (the latter of which is nice to know, but not as useful to me as the actual page that is visited). Under Recent Visitor Activity, I would like to *stop* seeing "Visit Page: Unknown". (Or, if you prefer, under Recent Pageload Activity, I would like to *stop* seeing "Unknown" between Host Name and Referrer. I want to see the URL that was visited.)

I have a hard time understanding why *every* browser on *every* computer or device at *every* physical location that I use to visit my own site behaves the same way: Some URLs are consistently noted by StatCounter and some URLs are consistently Unknown by StatCounter --- with identical StatCounter html code.

Assuming my confusion is misplaced, is there a way to convince the browser (at home, office, iphone and everywhere else) to stop blocking the referrer (or the URL visited)?
 
Last edited:
#12
The url of the visited page when using the html-only tracking code (which is an img tag), is the referrer to that image from the img tag. If the visitor's browser blocks the referrer you won't have that information.

Robots won't provide referrer information.

Many people these days will have enabled (on purpose or by default) various security/privacy options among them blocking the referrer, blocking third party images, blocking third party scripts, etc.
 
#13
Many people these days will have enabled (on purpose or by default) various security/privacy options among them blocking the referrer, blocking third party images, blocking third party scripts, etc.
I understand that many people have blocking enabled on their browsers. I do not. And I'm the one who is trying to test my links to see if the URLs I visit are recorded.

I'm grateful --- I really am --- for the repeated responses to my question. But, if I may say so, none of them actually *answers* the question that I keep asking:

Why, when I visit my own site, does StatCounter record the URLs of *some* of the my page visits, while indicating that the URLs of *other* pages --- on the same site with same StatCounter code --- are Unknown?

Browser-specific blocking seems (to me) to be beside the point. If blocking were enabled on my browser, it would, I imagine, prevent StatCounter from recording the URLs of *all* of my page visits to my own site, not just *some* of them.
 
#15
The good folks at the StatCounter Team solved my problem. I'm posting the answer here, in case others are similarly affected. As they explained, "The issue was the site uses https but the counter was using http. Switching the counter to https fixes the issue."

Evidently, my WordPress site does not like the code src="http://c.statcounter.com/..." So, replacing it with src="https://c.statcounter.com/..." did the trick.

I have no idea if this issue is endemic to WordPress or if it is unique to my service provider. In any case, this simple change worked for me.
 
Last edited:
#18
The good folks at the StatCounter Team solved my problem. I'm posting the answer here, in case others are similarly affected. As they explained, "The issue was the site uses https but the counter was using http. Switching the counter to https fixes the issue."

Evidently, my WordPress site does not like the code src="http://c.statcounter.com/..." So, replacing it with src="https://c.statcounter.com/..." did the trick.

I have no idea if this issue is endemic to WordPress or if it is unique to my service provider. In any case, this simple change worked for me.
As simple as adding the letter "S" to the code in widgets... This resolved my wordpress.com issue too - thank you for sharing, scoutthedog!!
 
Top