statcounter security certificate missing?

Status
Not open for further replies.
#1
For more then 3 years now, I have a simple html site with an invisible statcounter, works fine. Since a week or so, I'm getting this irritating popup 'revocation information for the security certificate for this site is not available'. It appears only once a day, not if I visit it a second or third time. I'm using IE6 on XP and did not change any settings or updates. I also did not change my website. I'm pretty confident that I have no spyware or viruses on my pc. Can I post the link or is this against the rules?

The certificate points to statcounter and godaddy. My knowledge to this stuff is very limited so I'm not sure what to dor. Anyway, it's not only irritating, but since this is my firm's site I'm afraid it might scare visitors off or it might affect my google ranking, which is vital for my business.

Many, many thanks in advance!
 
#2
Please post the url.

Is your site using https itself? That is the only time you'd need to use the https version of Statcounter. That is only available for upgraded accounts. if you are using https but your Statcounter project is not upgraded, then it won't work and you'd get such a problem.
 
#4
The Statcounter code you are using is this:

<!-- Start of StatCounter Code -->
<script type="text/javascript">
var sc_project=351994;
var sc_invisible=1;
var sc_partition=1;
var sc_security="";
var sc_https=1;
var sc_remove_link=1;
</script>

<script type="text/javascript" src="https://secure.statcounter.com/counter/counter_xhtml.js"></script><noscript><div class="statcounter"><img class="statcounter" src="https://c2.statcounter.com/counter.php?sc_project=351994&amp;java=0&amp;security=&amp;invisible=1" alt="free statistics" /></div></noscript>
<!-- End of StatCounter Code -->
Your site does not even work for https:
https://www.phongworks.be/

So I don't know why you picked the https version of Statcounter to use. And if you did, it wouldn't work unless your account is upgraded (i.e. paid up). Is it?


In any case you should not be using the https versions of Statcounter on your site. So change them all to http everywhere.
 
#5
That's weird indeed, a friend made this site 3 or 4 years ago and the code hasn't been changed since. My account hasn't changed eather, so I'm still using the free version.
So how do I solve this, should I just remove the 's' or is a completely different code?
And many thanks for helping me out so far Webado!
 
#7
That's weird indeed, a friend made this site 3 or 4 years ago and the code hasn't been changed since. My account hasn't changed eather, so I'm still using the free version.
So how do I solve this, should I just remove the 's' or is a completely different code?
And many thanks for helping me out so far Webado!
You can just replace https by http wherever you have it (as concerns Statcounter at least).


It used to be the https version was available for the free acctount too.

However the problem is right now that browsers are paranoic about security and privacy so now you get them complaining about invalid security certificate .
 
#8
Yey, It works!! There's also a line in the code that says: var sc_https=1; Should I leave this or set it to 0? Or also remove the 's'?
Sorry to keep this thread going, you probably understand that I don't have a clue what I'm doing :) My webdesign skills are limited to changing pretty pictures.
 
#12
"Invalid Security" Displays, and tracking has stopped??

Hello,

I launched the "Official Statcounter Plugin" for Wordpress a couple days ago. It was working fine, until this morning, it apparently stopped counting visitors, and now the message "Invalid Security" appears in the footer of my website, highlighted in blue. What's going on?

I tried creating a brand new security code and applying it, but that doesn't seem to help. Any suggestions?

You can see it happening on my site here -- just scroll to the very bottom of any page: http://www,garagespin.com

Thanks,

Mike
 
Last edited by a moderator:
#13
oh, it could be attributed to the instances of invalid code. http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.garagespin.com%2F

And you seem to be missing half of the statcounter code:

<!-- Start of StatCounter Code -->
<script type="text/javascript">
<!--
var sc_project=534145;
var sc_partition=46;
var sc_security="b9cb4bb9";
//-->
</script>
<script type="text/javascript" src="http://www.statcounter.com/counter/counter_xhtml.js"></script>

<noscript>It is missing the noscript portion of the js stuff that goes here.</noscript><!-- End of StatCounter Code -->
 
#14
Ok, thanks. I guess the statcounter WP plugin is broken, then. As always, sometimes it's better to handle such things yourself (and not through a plugin)!
 
Status
Not open for further replies.
Top